您的位置:首页 > 其它

2015暑假多校联合---CRB and His Birthday(01背包)

2016-09-02 20:46 344 查看
题目链接

http://acm.split.hdu.edu.cn/showproblem.php?pid=5410

[align=left]Problem Description[/align]
Today is CRB's birthday. His mom decided to buy many presents for her lovely son.
She went to the nearest shop with M Won(currency unit).
At the shop, there are N kinds of presents.
It costs Wi Won to buy one present of i-th kind. (So it costs k × Wi Won to buy k of them.)
But as the counter of the shop is her friend, the counter will give Ai × x + Bi candies if she buys x(x>0) presents of i-th kind.
She wants to receive maximum candies. Your task is to help her.
1 ≤ T ≤ 20
1 ≤ M ≤ 2000
1 ≤ N ≤ 1000
0 ≤ Ai, Bi ≤ 2000
1 ≤ Wi ≤ 2000

[align=left]Input[/align]
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains two integers M and N.
Then N lines follow, i-th line contains three space separated integers Wi, Ai and Bi.

[align=left]Output[/align]
For each test case, output the maximum candies she can gain.

[align=left]Sample Input[/align]

1

100 2

10 2 1

20 1 1

[align=left]Sample Output[/align]

21

Hint

CRB's mom buys 10 presents of first kind, and receives 2 × 10 + 1 = 21 candies.

[align=left]Author[/align]
KUT(DPRK)

[align=left]Source[/align]
2015 Multi-University Training Contest 10

[align=left]Recommend[/align]
wange2014

题意:输入M,N,分别表示总的钱数和物品种数,接下来输入N行,每行3个数,单价、买一件送的糖数 、买一次送的糖数 求最多能得到多少糖?

思路:01背包,dp[i]表示i钱下能得到最多的糖数,vis[i][j]表示i钱下得到最多糖时,是否买j物品,状态转移方程dp[i]=dp[i-kind[j][0]]+kind[j][1]+(vis[i-kind[j][0]][j]==0) * kind[j][2];

代码如下:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#define eps 1e-8
#define maxn 105
#define inf 0x3f3f3f3f3f3f3f3f
#define IN freopen("in.txt","r",stdin);
using namespace std;
int dp[2005];
int vis[2005][1005];
int kind[1005][3];

int main()
{
int T;
int M,N;
cin>>T;
while(T--)
{
scanf("%d%d",&M,&N);
for(int i=0;i<N;i++)
scanf("%d%d%d",&kind[i][0],&kind[i][1],&kind[i][2]);
memset(dp,0,sizeof(dp));
memset(vis,0,sizeof(vis));

for(int i=1;i<=M;i++)
{
int flag=-1;
for(int j=0;j<N;j++)
{
if(i<kind[j][0]) continue;
int s=dp[i-kind[j][0]]+kind[j][1];
if(!vis[i-kind[j][0]][j]) s+=kind[j][2];
if(dp[i]<s)
{
dp[i]=s;
flag=j;
}
}
if(flag>=0)
{
for(int j=0;j<N;j++)
{
vis[i][j]=vis[i-kind[flag][0]][j];
}
vis[i][flag]++;
}
}
int tmp=0;
for(int i=1;i<=M;i++)
tmp=max(tmp,dp[i]);
printf("%d\n",tmp);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: