您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之栈一:进制转换

2016-09-02 16:48 204 查看


Problem Description

输入一个十进制整数,将其转换成对应的R(2<=R<=9)进制数,并输出。


Input

第一行输入需要转换的十进制数;

第二行输入R。


Output

输出转换所得的R进制数。


Example Input

1279
8



Example Output

2377



Author

#include <bits/stdc++.h>
using namespace std;

int main()
{
int i,j,n,m,k;
stack <int> sta;

cin>>n>>m;

while(n>0)
{
sta.push(n%m);
n=n/m;
}
while(!sta.empty())
{
int key;
key=sta.top();
sta.pop();
cout<<key;
}
cout<<endl;
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: