您的位置:首页 > 其它

逆序建立链表

2016-09-02 16:35 204 查看


Problem Description

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。


Input

第一行输入整数N;;

第二行依次输入N个整数,逆序建立单链表。


Output

依次输出单链表所存放的数据。


Example Input

10
11 3 5 27 9 12 43 16 84 22



Example Output

22 84 16 43 12 9 27 5 3 11



Author

 
#include <bits/stdc++.h>

using namespace std;

struct node
{
int data;
struct node *next;
};

struct node *CreatList(int n)
{
struct node *head,*tail,*p;
int i;
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
tail=head;

for(i=0;i<n;i++)
{
p=(struct node *)malloc(sizeof(struct node));
cin>>p->data;
p->next=tail->next;
tail->next=p;
}
return (head);
};

int main()
{
struct node *head;
int i,j,k,m,n;

cin>>n;
head=CreatList(n);

struct node *r;

r=head->next;

while(r)
{
if(r->next==NULL)
cout<<r->data<<endl;
else
cout<<r->data<<" ";
r=r->next;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: