您的位置:首页 > 其它

hdu-1796-How many integers can you find(容斥)

2016-09-02 13:21 399 查看

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there
is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative
and won’t exceed 20.
 

Output
  For each case, output the number.
 
Sample Input
12 2
2 3
 

Sample Output
7

题意:

给定两整数n,m(n < 2^31,m<=10),接下来给定m个数的集合S,问小于n 的正整数有多少个数能被S中任一一个数整除。

题目链接:How many integers can you find

解题思路:

不大于n的且能被p整除的正整数有n/p个,但1~n中能整除p的数也可能整除q,因此可以用容斥,减去能整

除LCM(p,q)最小公倍数的个数,多个因子的话就类推下,奇加偶减嘛~

读取S集合时,记得把0排除了,否则会RE了。

一直用位集,就是状态压缩写,800ms过的,试了下DFS,171ms,不是很明白为什么差这么多。

代码:
#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdio>
#include <vector>
#include <algorithm>
#include <map>
#include <string>
#include <list>

using namespace std;
typedef long long LL;
int n, m, a[15];

int gcd(int a, int b)
{
return b == 0?a:gcd(b,a%b);
}

int main()
{
int cnt, num, t;
while(~scanf("%d%d",&n,&m)) {
cnt = 0;
for(int i = 0;i < m;i++) {
scanf("%d",&num);
if(num) a[cnt++] = num;
}
n --;
m = cnt;
int ans = 0;
for(int i = 1;i < (1<<m);i++) {
cnt = 0,  t = 1;
for(int j = 0;j < m;j++) {
if(i & (1<<j)) {
cnt ++;
t = t / gcd(t, a[j]) * a[j];
t = lcm(t,a[j]);
}
if(t > n){
break;
}
}
if(cnt & 1) ans += n/t;
else ans -= n/t;
}
printf("%d\n",ans);
}
return 0;
}
DFS 171MS
#include <iostream>//171MS	1728K
#include <cmath>
#include <cstring>
#include <cstdio>
#include <vector>
#include <algorithm>
#include <map>
#include <string>
#include <list>

using namespace std;
typedef long long LL;
int n, m, a[15], ans;

int gcd(int a, int b)
{
return b == 0?a:gcd(b,a%b);
}

void dfs(int l, int p, int k)
{
if(l > n || p >= m) return;
if(k & 1) {
ans += n/l;
}
else {
ans -= n/l;
}
for(int i = p+1;i < m;i++) {
dfs(l / gcd(l,a[i]) * a[i], i, k+1);
}
}
int main()
{
int cnt, num;
while(~scanf("%d%d",&n,&m)) {
cnt = 0;
for(int i = 0;i < m;i++) {
scanf("%d",&num);
if(num) a[cnt++] = num;
}
n --;
m = cnt;
ans = 0;
for(int i = 0;i < m;i++) {
dfs(a[i], i, 1);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息