您的位置:首页 > 其它

poj 1703 Find them, Catch them(带偏移量并查集)

2016-09-02 08:26 316 查看
poj 1703 Find them, Catch them(带偏移量并查集)

Time Limit: 1000ms Memory Limit: 65536kB

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

D [a] [b]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message “A [a] [b]” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”

Sample Input

1

5 5

A 1 2

D 1 2

A 1 2

D 2 4

A 1 4

Sample Output

Not sure yet.

In different gangs.

In the same gang.

Source

POJ Monthly–2004.07.18

昨天做了A bug’s life这一题才发现带偏移量并查集掌握的并不熟练,所以又做了一个题。

先讲这个题的小陷阱,题意每个黑帮至少有一个人(好坑的题意设定),所以n=2时候两个人肯定不是一个黑帮的。

再回顾一下带偏移量并查集(包括普通并查集)要注意的一个问题,比如合并x,y千万不要直接把find(x)直接接到y上,不然有可能成环!如果TLE&MLE,那么基本可以肯定是成环了,如果要直接接上去,要判定是否在同一个集合里。

Accepted    7296kB  161ms   924 B   G++


#define MAX_N 100000

#include<stdio.h>

int cases,n,m,x,y,fx,fy;
int root[MAX_N+1],rank[MAX_N+1];
char action;

int find(int x)
{
int r=root[x];
if (r==x)
return x;
else
{
root[x]=find(r);
rank[x]^=rank[r];
return root[x];
}
}

void test()
{
for (int i=1;i<=n;i++)
printf("%d(%d) ",root[i],rank[i]);
printf("\n");
return;
}

int main()
{
scanf("%d\n",&cases);
while (cases--)
{
scanf("%d%d\n",&n,&m);
for (int i=1;i<=n;i++)
{

root[i]=i;
rank[i]=0;
}
if (n==2)
{
rank[2]=1;
root[2]=1;
}
for (int i=1;i<=m;i++)
{
scanf("%c %d%d\n",&action,&x,&y);
if (action=='A')
{
if (find(x)!=find(y))
printf("Not sure yet.\n");
else if (rank[x]==rank[y])
printf("In the same gang.\n");
else
printf("In different gangs.\n");
}
else
{
fx=find(x);
fy=find(y);
root[fx]=fy;
rank[fx]=rank[x]^rank[y]^1;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: