您的位置:首页 > 理论基础 > 数据结构算法

HDU 5444 二叉树的遍历,先根据先序遍历建树

2016-09-01 21:23 501 查看
http://acm.split.hdu.edu.cn/showproblem.php?pid=5444


Elven Postman

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 1669    Accepted Submission(s): 951


Problem Description

Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs
through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully
like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having
the privilege to see the sunrise, which matters a lot in elven culture.

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it
encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

//这段话的意思是给出先序遍历

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.



 

Input

First you are given an integer T(T≤10) indicating
the number of test cases.

For each test case, there is a number n(n≤1000) on
a line representing the number of rooms in this tree. n integers
representing the sequence written at the root follow, respectively a1,...,an where a1,...,an∈{1,...,n}.

On the next line, there is a number q representing
the number of mails to be sent. After that, there will be q integers x1,...,xq indicating
the destination room number of each mail.

 

Output

For each query, output a sequence of move (E or W)
the postman needs to make to deliver the mail. For that E means
that the postman should move up the eastern branch and W the
western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.

 

Sample Input

2
4
2 1 4 3
3
1 2 3
6
6 5 4 3 2 1
1
1

 

Sample Output

E

WE
EEEEE

题意:在最初为空的二叉树中不断插入n个数。对于每个数,从根节点开始判断,如果当前节点为空,就插入当前节点,如果当前节点不为空,则小于当前节点的值,插入右子树,否则插入左子树。

接着q次询问,每次询问一个值在二叉树中从根节点开始的查找路径。

直接用二叉树模拟整个插入和询问的过程

<pre name="code" class="cpp">//hdu 5444  二叉树的遍历+建树

/*
HDU 5444
题意:在最初为空的二叉树中不断插入n个数。对于每个数,从根节点开始判断,如果当前节点为空,就插入当前节点,如果当前节点不为空,则小于当前节点的值,插入右子树,否则插入左子树。
接着q次询问,每次询问一个值在二叉树中从根节点开始的查找路径。

直接用二叉树模拟整个插入和询问的过程
*/
//从右往左排序
//从最右边开始,每次访问都是往右边未被访问的房间进行,
//访问完房间后,写下没有被访问的房间

/*
关键点: 中序遍历也可以理解成从最左开始标号一直标到最右

思路: 在最初为空的二叉树中不断的插入n个数.对于每个数,从根节点开始判断,
如果当前节点为空,就插入当前节点,如果当前节点不为空,则小于当前节点的值,插入右子树,
否则插入左子树.接着q次询问,每次询问一个值在二叉树中从根节点开始的查找路径.

这道题给出了先序遍历,默认的中序遍历是1.2....n
*/
#include <iostream>
#include <algorithm>
using namespace std;
//把图旋转180度当于给出了先序遍历
struct BST{ // binary search tree
int val;
BST *leftchild;
BST *rightchild;
BST (){}
BST(int x){ // 构造函数,初始化数据
val=x;
leftchild=rightchild=NULL;
}
};

void build(BST *&root,int data) //建树(会修改到root这棵树,所以用引用)
{
if (data<root->val)
{
if (root->leftchild==NULL)
root->leftchild=new BST(data);
else
build(root->leftchild,data);
}
else
{
if (root->rightchild==NULL)
root->rightchild=new BST(data);
else
build(root->rightchild,data);
}
}

void query(BST *root,int data) //只是进行查询,不会修改,所以只用指针就行
{
if (root->val==data)
{
puts("");
return;
}
else if (data<root->val)
{
putchar('E');
query(root->leftchild,data);
}
else
{
putchar('W');
query(root->rightchild,data);
}
}

int main()
{
int t;
scanf("%d",&t);
while (t--)
{
int n,rt,x;
scanf("%d",&n);
scanf("%d",&rt);
BST *root=new BST(rt);
for (int i=1;i<n;i++)
{
scanf("%d",&x);
build(root,x);
}
int q;
scanf("%d",&q);
for (int i=0;i<q;i++)
{
scanf("%d",&x);
query(root,x);
}
root=NULL;
}
return 0;
}


                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息