您的位置:首页 > 其它

2015暑假多校联合---Expression(区间DP)

2016-09-01 20:12 281 查看
题目链接

http://acm.split.hdu.edu.cn/showproblem.php?pid=5396

[align=left]Problem Description[/align]
Teacher Mai has n numbers a1,a2,⋯,anand n−1 operators("+", "-" or "*")op1,op2,⋯,opn−1, which are arranged in the form a1 op1 a2 op2 a3 ⋯ an.

He wants to erase numbers one by one. In i-th round, there are n+1−i numbers remained. He can erase two adjacent numbers and the operator between them, and then put a new number (derived from this one operation) in this position. After n−1 rounds, there is the only one number remained. The result of this sequence of operations is the last number remained.

He wants to know the sum of results of all different sequences of operations. Two sequences of operations are considered different if and only if in one round he chooses different numbers.

For example, a possible sequence of operations for "1+4∗6−8∗3" is 1+4∗6−8∗3→1+4∗(−2)∗3→1+(−8)∗3→(−7)∗3→−21.

[align=left]Input[/align]
There are multiple test cases.

For each test case, the first line contains one number n(2≤n≤100).

The second line contains n integers a1,a2,⋯,an(0≤ai≤109).

The third line contains a string with length n−1 consisting "+","-" and "*", which represents the operator sequence.

[align=left]Output[/align]
For each test case print the answer modulo 109+7.

[align=left]Sample Input[/align]

3

3 2 1
-+

5

1 4 6 8 3

+*-*

[align=left]Sample Output[/align]

2

999999689

Hint

Two numbers are considered different when they are in different positions.

[align=left]Author[/align]
xudyh

[align=left]Source[/align]
2015 Multi-University Training Contest 9

[align=left]Recommend[/align]
wange2014 | We have carefully selected several similar problems for you: 5867 5866 5865 5864 5863

题意:输入n个数,n-1个运算符(只有“+”、“—”、“*”),组成一个算式,给这n-1个运算符赋予不同的运算优先级(运算先后次序),每次得到一个值,求在所有值的和;

思路:区间DP,对于区间[i,j] 分为[i,k] 和[k+1,j] 设[i,k]在不同运算次序下的所有值为X1、X2、X3....Xn 那么dp[i][k]=(X1+X2+X3+...+Xn)
同样设dp[k+1][j]=(Y1+Y2+Y3+....+Ym) 如果第k个运算符为“*” dp[i][j]=X1*(Y1+...+Ym)+...+Xn*(Y1+...+Ym) =dp[i][k]*dp[k+1][j];
如果不是“*” dp[i][j]=dp[i][k]*A[j-1-k]+dp[k+1][j]*A[k-i] A[]表示排列,为什么要乘以排列数呢? 分析可知,对于区间[i,k]中的一个值对应区间[k+1][j]的所有 值,而后面区间中由运算符优先级得到的值的个数就是后面区间的运算符个数的排列数;
最后要乘上组合数,对于区间[i,j]分为[i,k] [k+1,j]的贡献次数是C[j-i][k-i] 为什么呢? 因为前后两个区间的运算优先级对彼此没有影响;

代码如下:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#define eps 1e-8
#define maxn 105
#define inf 0x3f3f3f3f3f3f3f3f
#define IN freopen("in.txt","r",stdin);
using namespace std;
const long long mod=1e9+7;
long long a[105];
char s[105];
long long dp[105][105];
long long A[120];
long long C[120][120];

int main()
{
int n;
A[0]=1;
for(long long i=1;i<=110;i++)  ///排列数;
A[i]=A[i-1]*i%mod;

for(int i=0;i<110;i++)         ///组合数;
C[i][0]=1;
C[1][1]=1;
for(int i=1;i<110;i++)
{
for(int j=1;j<=i;j++)
C[i][j]=(C[i-1][j-1]+C[i-1][j])%mod;
}
while(scanf("%d",&n)!=EOF)
{
for(int i=1;i<=n;i++)
scanf("%lld",&a[i]);
scanf("%s",s+1);
memset(dp,0,sizeof(dp));

for(int i=1;i<=n;i++)
dp[i][i]=a[i];

for(int len=2;len<=n;len++)
{
for(int i=1;i<=n;i++)
{
if(i+len-1>n) break;
for(int k=i;k<i+len-1;k++)
{
long long t;
if(s[k]=='*')
t=(dp[i][k]*dp[k+1][i+len-1])%mod;
else if(s[k]=='-')
t=(dp[i][k]*A[i+len-2-k]-dp[k+1][i+len-1]*A[k-i])%mod;
else
t=(dp[i][k]*A[i+len-2-k]+dp[k+1][i+len-1]*A[k-i])%mod;
dp[i][i+len-1]=(dp[i][i+len-1]+t*C[len-2][k-i])%mod;
}
}
}
printf("%lld\n",(dp[1]
%mod+mod)%mod);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: