您的位置:首页 > 其它

HDU 3746(KMP)next数组的运用

2016-09-01 18:03 375 查看
[align=left]Problem Description[/align]
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being
inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful
decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with
colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost
pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:



Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that
is to say, adding to the middle is forbidden.

CC is satisfied with his ideas and ask you for help.
 

[align=left]Input[/align]
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.

Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000
).
 

[align=left]Output[/align]
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 

[align=left]Sample Input[/align]

3
aaa
abca
abcde

 

[align=left]Sample Output[/align]

0
2
5
这道题首先要搞明白next数组的原理,next[i]表示的第i个字符前面的所有字符所存在的最大前缀和后缀的长度。举个例子:



AC代码

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int nxt[100005];
char s[100005];
int len;
void get_index()
{
int i,j;
i=0;
j=-1;
nxt[0]=-1;
while(i<=len)
{
if(j==-1||s[i]==s[j])
{
nxt[++i]=++j;
}
else
{
j=nxt[j];
}
}
}
int main()
{
int t;
scanf("%d",&t);
int pre_len;
int con;
while(t--)
{
con=0;
pre_len=0;
scanf("%s",&s);
len=strlen(s);
get_index();
pre_len=len-nxt[len];
if(len!=pre_len&&len%pre_len==0){
printf("0\n");
}else{
con=pre_len-len%pre_len;
printf("%d\n",con);
}

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  kmp string HDU