您的位置:首页 > 产品设计 > UI/UE

PAT 1007. Maximum Subsequence Sum (25)(dp动态规划)

2016-09-01 17:09 519 查看

题目

1007. Maximum Subsequence Sum (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10

-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

解题思路

1.感觉关键是用一个tem_left保存left,这样如果tem后面还有机会超过sum的话,那么就将更新left。

2.首先是用一个tem记录前面的最大和,然后判断,如果tem>sum则更新,如果0

AC代码

#include<cstdio>
#include<vector>

using namespace std;

int main(int argc, char *argv[])
{
int n;
scanf("%d",&n);
vector<int> num(n);
int tem = 0,left = 0, tem_left = 0,right = 0,sum = -1;
bool allZero = true;
for (int i = 0; i < n; ++i) {
scanf("%d",&num[i]);
//
if (allZero&&num[i]>=0) {
allZero = false;
}
//用tem记录前面i项的和
tem += num[i];
//如果tem>sum则更新
if (tem > sum) {
sum = tem;
right = i;
left = tem_left;
}else if (tem <= sum) {
//如果小于等于sum,如果小于零,则将tem置0,并用一个临时的
//tem_left保存left,这样如果tem后面还有机会超过sum的话,那么就将
//更新left
if (tem < 0) {
tem =0;
tem_left = i + 1;
}
}

}
if (allZero) {
printf("%d %d %d",0,num[0],num[n-1]);
}else {
printf("%d %d %d",sum,num[left],num[right]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  动态规划