您的位置:首页 > 运维架构

UVA - 11078 Open Credit System(维护最小值)

2016-08-31 12:13 483 查看
In an open credit system, the students can choose any course they like, but there is a problem. Some

of the students are more senior than other students. The professor of such a course has found quite a

number of such students who came from senior classes (as if they came to attend the pre requisite course

after passing an advanced course). But he wants to do justice to the new students. So, he is going to

take a placement test (basically an IQ test) to assess the level of difference among the students. He

wants to know the maximum amount of score that a senior student gets more than any junior student.

For example, if a senior student gets 80 and a junior student gets 70, then this amount is 10. Be careful

that we don’t want the absolute value. Help the professor to gure out a solution.

Input

Input consists of a number of test cases

T

(less than 20). Each case starts with an integer

n

which is

the number of students in the course. This value can be as large as 100,000 and as low as 2. Next

n

lines contain

n

integers where the

i

‘th integer is the score of the

i

‘th student. All these integers have

absolute values less than 150000. If

i < j

, then

i

‘th student is senior to the

j

‘th student.

Output

For each test case, output the desired number in a new line. Follow the format shown in sample

input-output section.

SampleInput

3

2

100

20

4

4

3

2

1

4

1

2

3

4

SampleOutput

80

3

-1

题解:

我太蠢了,只想到了线段树维护最小值,然后for枚举一遍,每次用线段树查最小值。

事实上这道题要求Ai-Aj最大,题目的意思就是如果你枚举Aj,那么Ai这个数就要求是0到j-1里面最大的,所以我们线性维护一遍就行了。

我这里从后面往前面维护,也是一样的。

线段树代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#pragma comment(linker, "/STACK:102400000,102400000")

const int maxn=1e5+5;
int A[maxn];

struct note {
int Min,left,right;
} a[maxn*4];

void init(int i,int l,int r) {
a[i].left=l,a[i].right=r;
if(l==r) {
a[i].Min=A[l];
return;
}
int mid=(l+r)>>1;
init(i<<1,l,mid);
init((i<<1) |1,mid+1,r);
a[i].Min=min(a[i<<1].Min,a[(i<<1)|1].Min);
}

int query(int i,int l,int r) {
if(a[i].left==l&&a[i].right==r) {
return a[i].Min;
}
int mid=(a[i].left+a[i].right)>>1;

if(l>mid)
return query((i<<1) |1,l,r);
else if(mid>=r)
return query(i<<1,l,r);
else
return min(query(i<<1,l,mid),query((i<<1) |1,mid+1,r));
}

int main() {
int n,T;
scanf("%d",&T);
while(T--) {
scanf("%d",&n);
for(int i=1; i<=n; ++i) {
scanf("%d",&A[i]);
}
init(1,1,n);
int ans=A[1]-A[2];
for(int i=1; i<n; ++i) {
ans=max(ans,A[i]-query(1,i+1,n));
}
printf("%d\n",ans);
}
return 0;
}


线性维护的代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn=1e5+5;
int A[maxn];

int main(){
int n,T;
scanf("%d",&T);
while(T--) {
scanf("%d",&n);
for(int i=1; i<=n; ++i) {
scanf("%d",&A[i]);
}
int Min=A
,ans=A[n-1]-A
;
for(int i=n-1;i>=1;--i){
ans=max(ans,A[i]-Min);
Min=min(A[i],Min);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: