您的位置:首页 > 其它

POJ 3186 Treats for the Cows (区间DP)

2016-08-30 16:40 337 查看
Treats for the Cows

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 5191 Accepted: 2712

Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:

The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.

Like fine wines and delicious cheeses, the treats improve with age and command greater prices.

The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).

Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.

Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5

1

3

1

5

2

Sample Output

43

Hint

Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

Source

USACO 2006 February Gold & Silver

由小区间推出大区间。不能采用固定区间结尾的方法。要采用区间长度递增的方法

一个大区间可以分为ai,[i+1,j]或者[i,j-1],aj那么ai或者aj出队的时候他的次序为n-( j – i )

#include "cstring"
#include "cstdio"
#include "iostream"
#include "string.h"
#include "algorithm"
using namespace std;
int v[2005];
int dp[2005][2005];
int main()
{
int n;
while(~scanf("%d",&n))
{
for(int i=1;i<=n;i++)
scanf("%d",&v[i]);
memset(dp,0,sizeof(dp));
for(int len=1;len<=n;len++)
{
for(int i=1;i+len-1<=n;i++)
{
int cnt=n-len+1;
dp[i][i+len-1]=max(dp[i][i+len-2]+v[i+len-1]*cnt,dp[i+1][i+len-1]+v[i]*cnt);
}
}
printf("%d\n",dp[1]
);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: