您的位置:首页 > 其它

PAT 1041 Linked List Sorting (25)(链表排序)

2016-08-30 09:00 471 查看

题目

1052. Linked List Sorting (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (< 105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [-105, 105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:
5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345
Sample Output:
5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1


解题思路

1.先根据头地址保存这个链表所有有效的队列,然后在排序就行了。

2.输出的时候要注意保存的链表为空的情况。

代码

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
int nx[99999],va[99999];
struct node{
int ad,v;
node(){}
node(int _ad,int _v){
this->ad = _ad;
this->v = _v;
}
};
bool cmp(const node &a, const node &b){
return a.v<b.v;
}

int main(int argc, char *argv[])
{
int n,f;
scanf("%d %d",&n,&f);
vector<node> b;
int tem_a,tem_b,tem_c;
for (int i = 0; i < n; ++i) {
scanf("%d %d %d",&tem_a,&tem_b,&tem_c);
nx[tem_a] = tem_c;
va[tem_a] = tem_b;
}
//将有效的链表存好
int now = f;
while (now != -1) {
b.push_back(node(now,va[now]));
now = nx[now];
}
//输出
if (!b.empty()) {
sort(b.begin(),b.end(),cmp);
printf("%d %05d\n",b.size(),b[0].ad);
for (int i = 0; i < b.size()-1; ++i) {
printf("%05d %d %05d\n",b[i].ad,b[i].v,b[i+1].ad);
}
printf("%05d %d %d\n",b[b.size()-1].ad,b[b.size()-1].v,-1);
}else {
printf("%d %d\n",0,-1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT