您的位置:首页 > 其它

Hust oj 1241 Blocks(暴力)

2016-08-29 23:50 183 查看
Blocks
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 74(29 users)Total Accepted: 46(27 users)Rating:







Special Judge: No
Description
Donald wishes to send a gift to his new nephew, Fooey. Donald is a bit of a traditionalist, so he has chosen to send a set of N classic baby blocks. Each block is a cube, 1 inch by 1 inch by 1 inch. Donald wants to stack the
blocks together into a rectangular solid and wrap them all up in brown paper for shipping. How much brown paper does Donald need?
Input
The first line of input contains C, the number of test cases. For each case there is an additional line containing N, the number of blocks to be shipped. N does not exceed 1000.
Output
Your program should produce one line of output per case, giving the minimal area of paper (in square inches) needed to wrap the blocks when they are stacked together.

Sample Input
5
9
10
26
27
100

Sample Output
30
34
82
54
130

纯暴力

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

int t;

int main()
{
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
int Min = 0x3f3f3f;
for(int i=1;i<=1000;i++)
{
if(i > n) break;
for(int j=1;j<=1000;j++)
{
if(i * j > n) break;
for(int k=1;k<=1000;k++)
{
if(i * j * k > n) break;
if(i * j * k == n && (2 * (i * j + i * k + j * k) < Min))
Min = 2 * (i * j + i * k + j * k);
}
}
}
printf("%d\n",Min);
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  哈理工oj1241