您的位置:首页 > 编程语言 > C#

HDU 5804 Price List (BC#86)

2016-08-28 19:15 375 查看


Price List

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)

Total Submission(s): 737    Accepted Submission(s): 420


Problem Description

There are n shops
numbered with successive integers from 1 to n in
Byteland. Every shop sells only one kind of goods, and the price of the i-th
shop's goods is vi.

Every day, Byteasar will purchase some goods. He will buy at most one piece of goods from each shop. Of course, he can also choose to buy nothing. Back home, Byteasar will calculate the total amount of money he has costed that day and write it down on his account
book.

However, due to Byteasar's poor math, he may calculate a wrong number. Byteasar would not mind if he wrote down a smaller number, because it seems that he hadn't used too much money.

Please write a program to help Byteasar judge whether each number is sure to be strictly larger than the actual value.

 

Input

The first line of the input contains an integer T (1≤T≤10),
denoting the number of test cases.

In each test case, the first line of the input contains two integers n,m (1≤n,m≤100000),
denoting the number of shops and the number of records on Byteasar's account book.

The second line of the input contains n integers v1,v2,...,vn (1≤vi≤100000),
denoting the price of the i-th
shop's goods.

Each of the next m lines
contains an integer q (0≤q≤1018),
denoting each number on Byteasar's account book.

 

Output

For each test case, print a line with m characters.
If the i-th
number is sure to be strictly larger than the actual value, then the i-th
character should be '1'. Otherwise, it should be '0'.

 

Sample Input

1
3 3
2 5 4
1
7
10000

 

Sample Output

001

分析:sum把所有商店的价值都加起来,判断输入的值是否比sum大即可。注意每组数据只为一行。

ACcode:

#include <stdio.h>
long long a;
int main()
{
int T;
int n,m;
int i;
scanf("%d",&T);
while(T--)
{
scanf("%d %d",&n,&m);
long long sum=0;
for(i=0;i<n;i++)
{
scanf("%I64d",&a);
sum+=a;
}
for(i=0;i<m;i++)
{
scanf("%I64d",&a);
if(a>sum)
printf("1");
else
printf("0");
}
putchar('\n');
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: