您的位置:首页 > 其它

POJ 1961 Period (KMP)

2016-08-28 15:08 337 查看
Period

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 16635 Accepted: 7999
Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is
one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 

number zero on it.
Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing
order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0

Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意:给定一个字符串,问这个字符串的所有前缀中,有哪些前缀可以由某个串重复k次组成,并且这个k最大是多少。这个k需要大于1。
分析:对next数组的一种应用;next数组其实保存的就是字符串的相似度;保存的是其前一个字符的前缀和后缀相等的最大值,假如next[i]的值为6,那么它的前一个字符前缀和后缀最多就有6个相等;
字符的编号从0开始,这里面就可以推出一个规律;那么if(i%(i-next[i])==0),则i前面的串为一个轮回串,其中轮回子串出现i/(i-next[i])次。
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1000000 + 10;
char str[maxn];
int next[maxn];
int len;
int cas;
int n;

void getNext()
{
int i = 0, j = -1;
next[0] = -1;
while (i != len){
if (j == -1 || str[i] == str[j]){
next[++i] = ++j;
}
else
j = next[j];
}
}

int main()
{
cas = 0;
while (scanf("%d", &len), len){
scanf("%s", str);
printf("Test case #%d\n", ++cas);
getNext();
for (int i = 2; i <= len; i++){
if (i % (i - next[i]) == 0 && i / (i - next[i]) != 1){
printf("%d %d\n", i, i / (i - next[i]));
}
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: