您的位置:首页 > 其它

POJ 1611 The Suspects 并查集简单题

2016-08-28 00:55 405 查看
The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 34126 Accepted: 16553
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 

Once a member in a group is a suspect, all members in the group are suspects. 

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1

Source

Asia Kaohsiung 2003

    题意:给定n个人,0号是感染者,和0号在一组则是嫌疑者,嫌疑者所在一组都是嫌疑者,求最终嫌疑者的个数。

    分析:并查集解决。将一组元素形成一个集合,如果集合当中有元素直接和0一组,则其所在的组中就引入了0,其中所有元素都是和0一组,最终遍历一遍判断和0一组的元素个数。见AC代码:

#include<stdio.h>
#include<set>
using namespace std;
const int maxn=30005;
int pre[maxn],num[505];
int a[30005];
int find(int x)
{
int r=x;
while (pre[r]!=r)
r=pre[r];
int i=x,j ;
while( i != r )
{
j=pre[i];
pre[i]=r ;
i=j;
}
return r ;
}
void join(int x,int y)             //判断x y是否连通,
{
int fx=find(x),fy=find(y);
if(fx!=fy)
pre[fx]=fy;
}
int main()
{
int n,m;
while(~scanf("%d%d",&n,&m)&&!(m==0&&n==0))
{
for(int i=0; i<n; i++)
pre[i]=i;//全部以自身为上级
int num;
for(int i=0; i<m; i++)
{
scanf("%d",&num);//一组元素合并成一个集合  只要这个集合中有元素和0 一个集合的话  那么所有的元素都是和0一个集合
//根据并查集的 性质 不管是队首元素和非队首元素 只要和0 一个集合  0就引入这个集合
//最终只需要遍历所有元素  和0是一个集合的话 则是感染者
scanf("%d",&a[0]);//全部以队首为上级
if(num>1)
{
for(int j=1; j<num; j++)
{
scanf("%d",&a[j]);
join(a[0],a[j]);
}
}
}
int sum=0,temp0=find(0);
for(int i=0; i<n; i++)
if(find(i)==temp0)
sum++;
printf("%d\n",sum);
}
}
    简单题一开始思路还是出现了偏差,还是水平不够……唯有多刷题。

    特记下,以备后日回顾。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: