您的位置:首页 > 其它

TOJ 1391.Hay Points

2016-08-26 16:39 295 查看
题目链接:http://acm.tju.edu.cn/toj/showp1391.html

1391. Hay Points

Time Limit: 1.0 Seconds Memory Limit: 65536K

Total Runs: 1226 Accepted Runs: 907


Each employee of a bureaucracy has a job description - a few paragraphs that describe the responsibilities
of the job. The employee's job description, combined with other factors, such as seniority, is used to determine his or her salary.
The Hay Point system frees the Human Resources department from having to make an intelligent judgement as to the value of the employee; the job description is merely scanned for words and phrases
that indicate responsibility. In particular, job descriptions that indicate control over a large budget or management over a large number of people yield high Hay Point scores.
You are to implement a simplified Hay Point system. You will be given a Hay Point dictionary and a number of job descriptions. For each job description you are to compute the salary associated with the
job, according to the system.
The first line of input contains 2 positive integers: m ≤ 1000, the number of words in the Hay Point dictionary, and n ≤ 100, the number of job descriptions. m lines follow; each
contains a word (a string of up to 16 lower-case letters) and a dollar value (a real number between 0 and 1,000,000). Following the dictionary are the njob descriptions. Each job description consists of one or more lines of text; for your convenience
the text has been converted to lower case and has no characters other than letters, numbers, and spaces. Each job description is terminated by a line containing a period.
For each job description, output the corresponding salary computed as the sum of the Hay Point values for all words that appear in the description. Words that do not appear in the dictionary have a value
of 0.

Sample Input

7 2
administer 100000
spending 200000
manage 50000
responsibility 25000
expertise 100
skill 50
money 75000
the incumbent will administer the spending of kindergarden milk money
and exercise responsibility for making change he or she will share
responsibility for the task of managing the money with the assistant
whose skill and expertise shall ensure the successful spending exercise
.
this individual must have the skill to perform a heart transplant and
expertise in rocket science
.

Sample Output

700150
150


Source: Waterloo
Local Contest Jun. 1, 2002

Submit List
Runs Forum
Statistics


水题,

Description

首先给出一字典,字典上每个单词有一个对应的键值,然后给出一段信息,让你输出这段信息的总键值,字典上没有出现过的单词键值为0

Input

第一行两个整数m和n,分别表示字典中单词个数和查询信息的条数,之后m行每行一个字符串和一个整数表示单词和其键值,然后是两段信息,每段信息以‘.’结束输入

Output

对于每段信息,输出其键值

#include <stdio.h>
#include <iostream>
using namespace std;
int main(){
string word[1001];
int salary[1001];
int m,n;
scanf("%d%d",&m,&n);
for(int i=0;i<m;i++)
cin>>word[i]>>salary[i];
while(n--){
int sum=0;
string ch;
while(cin>>ch&&ch!="."){
for(int i=0;i<m;i++)
if(ch==word[i]){
sum+=salary[i];
break;
}
}
printf("%d\n",sum);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  toj 水题