您的位置:首页 > 其它

HDU Danganronpa

2016-08-26 10:27 411 查看


Danganronpa

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0


Problem Description

Chisa Yukizome works as a teacher in the school. She prepares many gifts, which consist of n kinds
with a[i] quantities
of each kind, for her students and wants to hold a class meeting. Because of the busy work, she gives her gifts to the monitor, Chiaki Nanami. Due to the strange design of the school, the students' desks are in a row. Chiaki Nanami wants to arrange gifts like
this:

1. Each table will be prepared for a mysterious gift and an ordinary gift.

2. In order to reflect the Chisa Yukizome's generosity, the kinds of the ordinary gift on the adjacent table must be different.

3. There are no limits for the mysterious gift.

4. The gift must be placed continuously.

She wants to know how many students can get gifts in accordance with her idea at most (Suppose the number of students are infinite). As the most important people of her, you are easy to solve it, aren't you?

 

Input

The first line of input contains an integer T(T≤10) indicating
the number of test cases.

Each case contains one integer n.
The next line contains n (1≤n≤10) numbers: a1,a2,...,an, (1≤ai≤100000).

 

Output

For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the answer of Chiaki Nanami's question.

 

Sample Input

1
2
3 2

 

Sample Output

Case #1: 2

 

#include<stdio.h>

#include<string.h>

#include<iostream>

#include<algorithm>

#include<math.h>

using namespace std;

const int N = 100;

int a
;

int cmp(int x,int y)

{

    return x>y;

}

int main()

{

    int t, ncase=1;

    scanf("%d", &t);

    while(t--)

    {

        int n;

        scanf("%d", &n);

        memset(a,0,sizeof(a));

        int sum=0;

        for(int i=0;i<n;i++)

        {

            scanf("%d", &a[i]);

            sum+=a[i];

        }

        sum/=2;

        sort(a,a+n,cmp);

        int ans=0, flag=a[0];

        for(int i=1;i<n;i++)

        {

            if(a[i]>flag)

            {

                ans+=(2*flag);

                flag=a[i]-flag;

            }

            else if(a[i]<flag)

            {

                ans+=(2*a[i]);

                flag-=a[i];

            }

            else

            {

                sum+=(2*flag);

                flag=a[i+1];

                i++;

            }

            if(ans>=sum)

            {

                ans=sum;

                break;

            }

        }

        if(ans<sum&&flag>=2)

        {

            ans++;

        }

        printf("Case #%d: %d\n",ncase++,ans);

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: