您的位置:首页 > 其它

【lightoj1305】 Area of a Parallelogram

2016-08-25 19:50 399 查看
B - B 圆周率用acos(-1.0) 使用longlong
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit Status Practice LightOJ
1305 

uDebug


Description

A parallelogram is a quadrilateral with two pairs of parallel sides. See the picture below:



Fig: a parallelogram
Now you are given the co ordinates of A, B and C, you have to find the coordinates of D and the area of the parallelogram. The orientation of ABCD should be same as in the picture.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing six integers Ax, Ay, Bx, By, Cx, Cy where (Ax, Ay) denotes the coordinate of A(Bx,
By)
 denotes the coordinate of B and (Cx, Cy) denotes the coordinate of C. Value of any coordinate lies in the range [-1000, 1000]. And you can assume
that A, B and C will not be collinear.

Output

For each case, print the case number and three integers where the first two should be the coordinate of D and the third one should be the area of the parallelogram.

Sample Input

3

0 0 10 0 10 10

0 0 10 0 10 -20

-12 -10 21 21 1 40

Sample Output

Case 1: 0 10 100

Case 2: 0 -20 200

Case 3: -32 9 1247

要考虑斜率不存在的情况,就是分母为0的时候,坑的我,哎,不说了。另外面积输出要四舍五入,虽然他说输入三个整数,但不能直接(int)类型转换,否则出现误差。

#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int main() {
int T,p=0;
scanf("%d",&T);
while(T--) {
int x1,x2,x3,y1,y2,y3;
scanf("%d%d%d%d%d%d",&x1,&y1,&x2,&y2,&x3,&y3);
int x4,y4;
x4=x1+x3-x2;
y4=y1+y3-y2;
double s,k,l,d;
if(x1==x2) {
s=(double)abs(y2-y1)*(double)abs(x4-x1);
} else {
k=(double)(y2-y1)/(double)(x2-x1);
l=fabs((double)(k*x4-y4-k*x1+y1))/(double)sqrt(k*k+1.0);
d=(double)sqrt((double)(x2-x1)*(x2-x1)+(double)(y2-y1)*(y2-y1));
s=l*d;
}
printf("Case %d: %d %d %.lf\n",++p,x4,y4,s);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数学 几何