您的位置:首页 > 其它

周赛

2016-08-25 17:17 197 查看
F 圆周率用acos(-1.0) 使用longlong
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Submit Status Practice LightOJ
1331

uDebug


Description

Agent J is preparing to steal an antique diamond piece from a museum. As it is fully guarded and they are guarding it using high technologies, it's not easy to steal the piece. There are three circular laser scanners in the museum which
are the main headache for Agent J. The scanners are centered in a certain position, and they keep rotating maintaining a certain radius. And they are placed such that their coverage areas touch each other as shown in the picture
below:



Here R1, R2 and R3 are the radii of the coverage areas of the three laser scanners. The diamond is placed in the place blue shaded region as in the picture. Now your task
is to find the area of this region for Agent J, as he needs to know where he should land to steal the diamond.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing three real numbers denoting R1, R2 and R3 (0 < R1, R2, R3 ≤ 100). And no number contains more than two digits after
the decimal point.

Output

For each case, print the case number and the area of the place where the diamond piece is located. Error less than 10-6 will be ignored.

Sample Input

3

1.0 1.0 1.0

2 2 2

3 3 3

Sample Output

Case 1: 0.16125448

Case 2: 0.645017923

Case 3: 1.4512903270

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int main()
{
int t,cont=0;
double r1,r2,r3,s0,s1,s2,s3,s;
double a,b,c;
double cin1,cin2,cin3,sin3;
scanf("%d",&t);
while(t--)
{
scanf("%lf%lf%lf",&r1,&r2,&r3);
a=r2+r3;
b=r1+r3;
c=r1+r2;
cin1=(b*b+c*c-a*a)/(2*b*c);
cin2=(a*a+c*c-b*b)/(2*a*c);
cin3=(a*a+b*b-c*c)/(2*a*b);
sin3=sqrt(1-pow(cin3,2));
s0=abs(0.5*a*b*sin3);
s1=abs((acos(cin1)/(2*acos(-1.0)))*(acos(-1.0)*r1*r1));
s2=abs((acos(cin2)/(2*acos(-1.0)))*(acos(-1.0)*r2*r2));
s3=abs((acos(cin3)/(2*acos(-1.0)))*(acos(-1.0)*r3*r3));
s=s0-s1-s2-s3;
printf("Case %d: %.9lf\n",++cont,s);
}
return 0;
}//FFFFFFFFFFFFFF
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  小数学