您的位置:首页 > 运维架构

POJ C Looooops 2115 (扩展欧几里得)

2016-08-25 11:25 274 查看
C Looooops

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 23143 Accepted: 6357
Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)
statement;


I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming
that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k. 

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C
< 2k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input
3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output
0
2
32766
FOREVER

Source

CTU Open 2004
题意:给出a,b,c,k,算(a+x*c)%2^k是否等于b
分析:扩展欧几里得最小整数解 可以把上面的方程转成 a*x + 2^k*y = b

如果没有整数解,则永远到不了,套模板,这里有模板点击打开链接

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <stdlib.h>
using namespace std;
long long x,y;
long long e_gcd(long long a,long long b,long long &x,long long &y)
{
if(b==0)
{
x=1;
y=0;
return a;
}
long long ans=e_gcd(b,a%b,x,y);
long long temp;
temp=x;
x=y;
y=temp-a/b*y;
return ans;
}
int main()
{
long long a,b,c,d,n,m,k,l;
while(~scanf("%lld%lld%lld%lld",&a,&b,&c,&k))
{
if(a==0 && b==0 && c==0 && k==0)
break;
n=c;
m=1LL<<k;
l=b-a;
d=e_gcd(n,m,x,y);
if(l%d!=0)
printf("FOREVER\n");
else
{
x=x*(l/d);
m=m/d;
printf("%lld\n",((x%m)+m)%m);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj 数论