您的位置:首页 > 其它

微分方程_______Rower Bo( HDU 5761 2016多校第三场)

2016-08-24 21:39 295 查看
Problem Description

There is a river on the Cartesian coordinate system,the river is flowing along the x-axis direction.

Rower Bo is placed at (0,a) at
first.He wants to get to origin (0,0) by
boat.Boat speed relative to water is v1,and
the speed of the water flow is v2.He
will adjust the direction of v1 to
origin all the time.

Your task is to calculate how much time he will use to get to origin.Your answer should be rounded to four decimal places.

If he can't arrive origin anyway,print"Infinity"(without quotation marks).

 

Input

There are several test cases. (no more than 1000)

For each test case,there is only one line containing three integers a,v1,v2.

0≤a≤100, 0≤v1,v2,≤100, a,v1,v2 are
integers

 

Output

For each test case,print a string or a real number.

If the absolute error between your answer and the standard answer is no more than 10−4,
your solution will be accepted.

 

Sample Input

2 3 3
2 4 3

 

Sample Output

Infinity
1.1428571429

 

题意:

最开始在(0,a)点有一艘船,水流方向朝向X轴正方向,速度为V1,船的速度为V2,船在行驶过程中速度方向一直朝向原点。问多久才能到达原点?

分析:

因为速度是变方向,所以要用积分来做,最开始我对距离积分没算出来,后来看了题解才知道要分别对X轴方向和斜轴方向积分。

,我们换一个思路,不分解v1分解v2,在斜方向上对速度积分,得到这样一个式子: 

∫T0(v1−cosθ⋅v2) dt=a

    可以看到在这样一个式子里,我们只有cosθ,于是我们把这个式子和前面在x轴方向上积分的式子 

∫T0(v2−cosθ⋅v1) dt=0

    联立,消去cosθ就行了。 
    最终得到

T=v1av21−v22

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>

using namespace std;

int a,v1,v2;

int main()
{
while(scanf("%d%d%d",&a,&v1,&v2)!=EOF)
{
if (a==0) { printf("0\n"); continue ; }
if (v1<=v2)
{
printf("Infinity\n");
continue ;
}
double t= 1.0*a*v1/(v1*v1-v2*v2);
printf("%lf\n",t);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息