您的位置:首页 > 其它

POJ-1383-Labyrinth(广搜最大直径)

2016-08-24 20:54 369 查看
Labyrinth

Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 3990 Accepted: 1501
Description

The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have
found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means
also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow,
each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks
are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth. 

The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.

Output

Your program must print exactly one line of output for each test case. The line must contain the sentence "Maximum rope length is X." where Xis the length of the longest path between any two free blocks, measured in blocks.

Sample Input
2
3 3
###
#.#
###
7 6
#######
#.#.###
#.#.###
#.#.#.#
#.....#
#######


Sample Output
Maximum rope length is 0.
Maximum rope length is 8.


Hint

Huge input, scanf is recommended. 

If you use recursion, maybe stack overflow. and now C++/c 's stack size is larger than G++/gcc

题意:

思路:首先找到任意一个' . '的坐标(x1, y1),然后以该坐标为起点BFS整个迷宫找最长路,找到该坐标对应最长路的终点(x2, y2)。再以(x2, y2)为起点BFS整个迷宫找最长路即可。

#include <stdio.h>
#include <string.h>
#include <queue>
#include <algorithm>
using namespace std;
struct Node
{
int x, y, step;
};
Node now, next;
int N, M;
char Map[1100][1100];
bool vis[1100][1100];
int sx, sy;
int ans;//最长路 最后的结果
bool judge(int x, int y)//判断下一位的移动是否合法
{
return x >= 0 && x < N && y >= 0 && y < M && Map[x][y] != '#' && !vis[x][y];
}
void BFS(int x, int y)
{
queue<Node> Q;
int move[4][2] = {0,1, 0,-1, 1,0, -1,0};
memset(vis, false, sizeof(vis));
Node now = {x, y, 0};
Q.push(now);
ans = 0;
while(!Q.empty())
{
now = Q.front();
Q.pop();
for(int k = 0; k < 4; k++)
{
next.x = now.x + move[k][0];
next.y = now.y + move[k][1];
next.step = now.step + 1;
if(judge(next.x, next.y))
{
vis[next.x][next.y] = true;
if(next.step > ans)
{
ans = next.step;
sx = next.x;
sy = next.y;
}
Q.push(next);
}
}
}
}
int main()
{
int t;
scanf("%d", &t);
while(t--)
{
scanf("%d%d", &M, &N);
bool flag = false;
for(int i = 0; i < N; i++)
{
scanf("%s", Map[i]);
if(flag) continue;//找到一个 不用再找第二个
for(int j = 0; j < M; j++)
{
if(Map[i][j] == '.')
{
sx = i;
sy = j;
flag = true;
}
}
}
BFS(sx, sy);//找S-T端点
BFS(sx, sy);//找最长路
printf("Maximum rope length is %d.\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: