您的位置:首页 > 其它

Light oj 1045 (求某个数的阶乘在x进制下的位数)

2016-08-24 20:17 316 查看
Digital Of factorial

Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit Status Practice LightOJ
1045 

uDebug


Description

Factorial of an integer is defined by the following function

f(0) = 1

f(n) = f(n - 1) * n, if(n > 0)

So, factorial of 5 is 120. But in different bases, the factorial may be different. For example, factorial of 5 in base 8 is 170.

In this problem, you have to find the number of digit(s) of the factorial of an integer in a certain base.

Input

Input starts with an integer T (≤ 50000), denoting the number of test cases.

Each case begins with two integers n (0 ≤ n ≤ 106) and base (2 ≤ base ≤ 1000). Both of these integers will be given in decimal.

Output

For each case of input you have to print the case number and the digit(s) of factorial n in the given base.

Sample Input

5

5 10

8 10

22 3

1000000 2

0 100

Sample Output

Case 1: 3

Case 2: 5

Case 3: 45

Case 4: 18488885

Case 5: 1

题意:求数N!在x进制下的位数;

N !在10进制下的位数为log10 (n!) + 1;  所以在x进制下的位数为logx (n!) + 1;

但是计算机只能表示以10和e为底的对数,所以要用换底公式,logx (n!) = log(n!) /  log(x);

log (n!)=log1 + log2 + log3 + log4 +……+log(n),所以n比较大时计算log(n!)时已经把其他数的阶乘也算出来了,

如果给出一个n都要计算阶乘的话,费时间o(n),所以可以把log (n!) 先用double型数组sum[]先存起来,令sun[i]=log(i!)

先预处理出sum[i]后面可直接调用;

代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
double sum[1000009];//数组要是double型的;
int main()
{
memset(sum,0,sizeof(sum));
sum[1]=log(1);
for(int i=2;i<=1000000;i++)
{
sum[i]=sum[i-1]+log(i);
}
int t,n,b,mm=1;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&b);
if(n==0)
{
printf("Case %d: 1\n",mm++);//0的阶乘等于1,此时不能用sum[0],因为真数不能为0不符合所以要单独列出;
}
else
{
int c;//定义一个整形c,把double强制转换成int ;
c=sum
/log(b)+1;
printf("Case %d: %d\n",mm++,c);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: