您的位置:首页 > 其它

lightoj 1138 (二分)

2016-08-23 21:36 399 查看

lightoj 1138

Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero
on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5
Case 2: 10
Case 3: impossible
【题意】有些N!的末尾会是几个连续的0,找含Q个0的N!的最小N值;

【思路】用二分法,从区间【0, oo(无穷大)】查找,注意判断N!的末尾有几个0,。

AC代码:
#include<cstdio>
#define LL long long
LL sum(LL N)//求N阶乘中 末尾连续的0的个数
{
LL ans = 0;
while(N)
{
ans += N / 5;
N /= 5;
}
return ans;
}
int k = 1;
int main()
{
int t;
LL Q;
scanf("%d", &t);
while(t--)
{
scanf("%lld", &Q);
LL left = 1, right = 1000000000000;
LL ans = 0;
while(right >= left)
{
int mid = (left + right) >> 1;
if(sum(mid) == Q)//相等时 要赋值给ans
{
ans = mid;
right = mid - 1;//找的是最小的ans
}
else if(sum(mid) > Q)
right = mid - 1;
else
left = mid + 1;
}
printf("Case %d: ", k++);
if(ans)
printf("%lld\n", ans);
else
printf("impossible\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: