您的位置:首页 > 大数据 > 人工智能

Lightoj 1282 (Leading and Trailing)

2016-08-23 21:26 363 查看
Leading and Trailing

Description

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669 

题意:求n^k的前三位和后三位。

题解:快速幂,学到了一个函数fmod( x ,y ),返回的是x/y的余数,也可以是小数。后三位采用快速幂取余,前三位采用详见:n^k就等于10^ak,这里把ak分为两部分,整数和小数部分,即x和y,那么n^k = 10^x * 10^y,由于x是整数,那么很明显他是用来指定位数的,因为10^x肯定是一个10,
100, 10000...之类的数字,也就是说10^y才是这个数字的有效部分,我们只要求出10^y,然后乘上100最终结果就是我们想要的。因为n = 10^a  所以 a = log10(n),10^y就是小数部分,我们用函数fmod(x, 1),返回x的小数部分,然后乘上100即可,fmod返回的是y的值,所以必须计算10^y才是真实值,所以直接使用10^2 * 10^y 即pow(10, 2 + y).

#include<cstdio>
#include<cmath>
using namespace std;

long long q(long long n,long long k){//快速幂取余
long long s=1;
while (k){
if (k&1)
s=s*n%1000;
n=n*n%1000;
k>>=1;
}
return s;
}
int main(){
int t,cas=1;
long long n,k;
scanf ("%d",&t);
while (t--){
scanf ("%lld %lld",&n,&k);
printf ("Case %d: ",cas++);
long long ans=q(n,k);//后三位
long long sum=pow(10.0,2.0+fmod((double)k*log10((double)n),1));//前三位
printf ("%lld %03lld\n",sum,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: