您的位置:首页 > 其它

Lightoj 1045 (数学题)

2016-08-23 19:54 239 查看
Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu

Submit

Status

Description

Factorial of an integer is defined by the following function

f(0) = 1

f(n) = f(n - 1) * n, if(n > 0)

So, factorial of 5 is 120. But in different bases, the factorial may be different. For example, factorial of 5 in base 8 is 170.

In this problem, you have to find the number of digit(s) of the factorial of an integer in a certain base.

Input

Input starts with an integer T (≤ 50000), denoting the number of test cases.

Each case begins with two integers n (0 ≤ n ≤ 106) and base (2 ≤ base ≤ 1000). Both of these integers will be given in decimal.

Output

For each case of input you have to print the case number and the digit(s) of factorial n in the given base.

Sample Input

5

5 10

8 10

22 3

1000000 2

0 100

Sample Output

Case 1: 3

Case 2: 5

Case 3: 45

Case 4: 18488885

Case 5: 1

题意:求 n 的阶乘在 base 进制下的位数,这里有一个简单的方法,就是log10(n)+ 1就是 n 的在十进制下的位数,由此可知 log base(n) 就是n在base 进制下的位数,再根据换底公式,log base(n) == log(n)/ log(base),这里让求的是阶乘,根据log的原理呢,就有log base (n!) == ( log(n) + log(n-1) + log(n-2) + 。。。。+ log(1)) / log(base)。用 sum 数组存一下 log(n!) 就可以快速的求出了

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
#define M 1000010
#define LL long long
#define MOD (1000000000 + 7)
#define CRL(a, b) memset(a, b, sizeof(a))

double sum[M];

void getlog()
{
sum[0] = 0;
for(int i=1; i<M; i++)
{
sum[i] = sum[i-1] + log((double) i);
}
}
int main()
{
int t;
LL n, m;
scanf("%d", &t);
getlog();
for(int ca=1; ca<=t; ca++)
{
scanf("%lld%lld", &n, &m);
LL ans = 0;
if(n == 0)
{
ans = 1;
}
else
{
ans = (int)(sum
/ log(m)) + 1;
}
printf("Case %d: %lld\n", ca,  ans);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: