您的位置:首页 > 大数据 > 人工智能

1282 - Leading and Trailing

2016-08-23 18:18 507 查看
1282
- Leading and Trailing

Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit Status Practice LightOJ
1282 

uDebug


Description

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

#include<stdio.h>
#include<math.h>
#define ll __int64
#include<algorithm>
using namespace std;

ll QuackMod(ll a,ll b,ll mod) {
ll ans;
if(!b) return 1;
ans=QuackMod(a*a%mod,b/2,mod);
if(b&1) ans=ans*a%mod;
return ans;
}

int main() {
int t;
scanf("%d",&t);
for(int j=1; j<=t; j++) {
ll n,k;
scanf("%I64d%I64d",&n,&k);
int strat=(int)pow(10.0,2.0+fmod(k*log10(n*1.0),1.0));
int end=(int)QuackMod(n,k,1000);
printf("Case %d: %d %03d\n",j,strat,end);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: