您的位置:首页 > 其它

Jan's LightOJ :: Problem 1045 - Digits of Factorial

2016-08-23 18:17 375 查看


Jan's
LightOJ :: Problem 1045 - Digits of Factorial

E - E 使用long long
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit Status Practice LightOJ
1045 

uDebug


Description

Factorial of an integer is defined by the following function

f(0) = 1

f(n) = f(n - 1) * n, if(n > 0)

So, factorial of 5 is 120. But in different bases, the factorial may be different. For example, factorial of 5 in base 8 is 170.

In this problem, you have to find the number of digit(s) of the factorial of an integer in a certain base.

Input

Input starts with an integer T (≤ 50000), denoting the number of test cases.

Each case begins with two integers n (0 ≤ n ≤ 106) and base (2 ≤ base ≤ 1000). Both of these integers will be given in decimal.

Output

For each case of input you have to print the case number and the digit(s) of factorial n in the given base.

Sample Input

5

5 10

8 10

22 3

1000000 2

0 100

Sample Output

Case 1: 3

Case 2: 5

Case 3: 45

Case 4: 18488885

Case 5: 1

#include<iostream>
#include<stdio.h>
#include<cmath>
using namespace std;

double logg[1000001];

int main()
{
int t, n, base;
cin >> t;
logg[0] = 0;
for (int i = 1; i < 1000001; i++)logg[i] += logg[i - 1] + log(i);
for (int i = 1; i <= t; i++)
{
scanf("%d%d", &n, &base);
printf("Case %d: %d\n", i, int(logg
/log(base)) + 1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: