您的位置:首页 > 其它

【HDU】-5671-Matrix(思维,好)

2016-08-23 10:46 211 查看

Matrix

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 1398    Accepted Submission(s): 557


Problem Description

There is a matrix M that
has n rows
and m columns (1≤n≤1000,1≤m≤1000).Then
we perform q(1≤q≤100,000) operations:

1 x y: Swap row x and row y (1≤x,y≤n);

2 x y: Swap column x and column y (1≤x,y≤m);

3 x y: Add y to all elements in row x (1≤x≤n,1≤y≤10,000);

4 x y: Add y to all elements in column x (1≤x≤m,1≤y≤10,000);
 

Input

There are multiple test cases. The first line of input contains an integer T(1≤T≤20) indicating
the number of test cases. For each test case:

The first line contains three integers n, m and q.

The following n lines
describe the matrix M.(1≤Mi,j≤10,000) for
all (1≤i≤n,1≤j≤m).

The following q lines
contains three integers a(1≤a≤4), x and y.

 

Output

For each test case, output the matrix M after
all q operations.
 

Sample Input

2
3 4 2
1 2 3 4
2 3 4 5
3 4 5 6
1 1 2
3 1 10
2 2 2
1 10
10 1
1 1 2
2 1 2

 

Sample Output

12 13 14 15
1 2 3 4
3 4 5 6
1 10
10 1

看代码理解吧:#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define CLR(a,b) memset(a,b,sizeof(a))
int a[1010][1010];
int row[1010],rad[1010],cul[1010],cad[1010];
int main()
{
int u, n,m,p;
scanf("%d",&u);
while(u--)
{
CLR(a,0);
CLR(row,0),CLR(rad,0);
CLR(cul,0),CLR(cad,0);
scanf("%d%d%d",&n,&m,&p);
for(int i=1;i<=n;i++)
row[i]=i,rad[i]=0;
for(int i=1;i<=m;i++)
cul[i]=i,cad[i]=0;
for(int i=1;i<=n;i++)
for(int j=1;j<=m;j++)
scanf("%d",&a[i][j]);
int op,x,y;
while(p--)
{
scanf("%d%d%d",&op,&x,&y);
if(op==1)
swap(row[x],row[y]) ;
else if(op==2)
swap(cul[x],cul[y]);
else if(op==3)
rad[row[x]]+=y;
else
cad[cul[x]]+=y;
}
for(int i=1;i<=n;i++)
{
for(int j=1;j<=m;j++)
{
if(j>1)
printf(" ");
printf("%d",a[row[i]][cul[j]]+rad[row[i]]+cad[cul[j]]);
}
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: