您的位置:首页 > 其它

HDU 3555 Bomb [数位DP]【动态规划】

2016-08-22 20:34 387 查看
题目链接 :HDU最近比较炸 不贴链接了、、

——————.

Bomb

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 15374 Accepted Submission(s): 5565

Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.

Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

Output

For each test case, output an integer indicating the final points of the power.

Sample Input

3

1

50

500

Sample Output

0

1

15

Hint

From 1 to 500, the numbers that include the sub-sequence “49” are “49”,”149”,”249”,”349”,”449”,”490”,”491”,”492”,”493”,”494”,”495”,”496”,”497”,”498”,”499”,

so the answer is 15.

———————————-.

题目大意 : 就是问你从1~m 里 有49的数的个数

解题思路 :

最最基础的数位DP

附本题代码

——————————————————.

#include <bits/stdc++.h>

using namespace std;

#define LL long long int

LL  dp[30][12][2];
//    位数  数字0~9  状态
int num[30],len ;
//  数字   长度

/**********记忆化搜索****************/
//分别代表现在的位数 上一位的数字 限制  状态

/*
主要就是限制
比如说m = 123456789;
那么位数到地5位的时候 就不能选6 7 ..等等了
但是如果在第5位他选择了 4  那么下一位就能够任意选择了 、
*/
/*
状态就是表示 到现在 有没有他能够满足的状态  有就+1  没有就+0;ll
*/

LL dfs(int pos ,int x,int limit ,int status)
{
if(pos<0)  return status;

if(dp[pos][x][status]!=-1&&!limit)
return dp[pos][x][status];

int endi=9;
if(limit) endi = num[pos];

LL res = 0;
for(int i=0;i<=endi;i++)
{
res+=dfs(pos-1 ,i ,limit&&(i==endi) ,status||(i==9&&x==4) );
}

if(!limit) dp[pos][x][status] =  res;
return  res;
}

int main()
{

memset(dp,-1,sizeof(dp));
int _;
scanf("%d",&_);
while(_--)
{
LL n;
scanf("%I64d",&n);
LL tem = n;
len = 0;
while(tem)
{
num[len++]=tem%10;
tem/=10;
}
LL m = dfs(len-1,0,1,0);

printf("%I64d\n",m);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: