您的位置:首页 > 其它

poj 2352 && hdu 1541 Stars (树状数组)

2016-08-22 20:31 573 查看
Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not
to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There
can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars
of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5


Sample Output

1
2
1
1
0


Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

这题要注意到他的简便方法,主要是由于是从低到高从左到右,那么我们可以看成每次提升高度加入的点,就是对原来的那一行上的点的增加,又因为新增加的点不算,我们直接向前求和就是解了,对应的那一类个数加一,之后再更新一下原来那一行上的点,就是新增点对应的那个个数加一,依次类推,就行。

#include <stdio.h>

int c[32000+10];
int ans[15000+10];
int n=32000+10;

int lowbit(int k)
{
return (k&(-k));
}

int sum(int x) //求和
{
int ret = 0;
while(x>0)
{
ret+=c[x];
x-=lowbit(x);
}
return ret;
}

void add(int x,int d) //修改节点的值
{
while(x<=n)
{
c[x]+=d;
x+=lowbit(x);
}
}

int main()
{
int n1;
scanf("%d",&n1);
int i;
for(i=0;i<n1;i++)
{
int x,y;
scanf("%d%d",&x,&y);
ans[sum(x+1)]++;
add(x+1,1);
}
for(i=0;i<n1;i++)
{
printf("%d\n",ans[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: