您的位置:首页 > 其它

HDU 5671 Matrix

2016-08-22 11:48 225 查看

Matrix

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 1398    Accepted Submission(s): 557


[align=left]Problem Description[/align]
There is a matrix M
that has n
rows and m
columns (1≤n≤1000,1≤m≤1000).Then
we perform q(1≤q≤100,000)
operations:

1 x y: Swap row x and row y (1≤x,y≤n);

2 x y: Swap column x and column y (1≤x,y≤m);

3 x y: Add y to all elements in row x (1≤x≤n,1≤y≤10,000);

4 x y: Add y to all elements in column x (1≤x≤m,1≤y≤10,000);
 

[align=left]Input[/align]
There are multiple test cases. The first line of input contains an integer
T(1≤T≤20)
indicating the number of test cases. For each test case:

The first line contains three integers n,
m
and q.

The following n
lines describe the matrix M.(1≤Mi,j≤10,000)
for all (1≤i≤n,1≤j≤m).

The following q
lines contains three integers a(1≤a≤4),
x
and y.

 

[align=left]Output[/align]
For each test case, output the matrix
M
after all q
operations.
 

[align=left]Sample Input[/align]

2
3 4 2
1 2 3 4
2 3 4 5
3 4 5 6
1 1 2
3 1 10
2 2 2
1 10
10 1
1 1 2
2 1 2

 

[align=left]Sample Output[/align]

12 13 14 15
1 2 3 4
3 4 5 6
1 10
10 1

Hint Recommand to use scanf and printf

 

[align=left]Source[/align]
BestCoder Round #81 (div.2)

 

[align=left]Recommend[/align]
wange2014
 

这个题好费脑子啊TAT英语很简单,不翻译了。

就是把最先开始的地图的顺序当做二维数组存起来。然后二维数组的角标是不断更新的地图。最后按照角标顺序输出原地图就好。

就是两个图转换这块想起来感觉脑袋都要打弯了= =

#include<stdio.h>
#include<string.h>
int map[1010][1010],x[1010],y[1010];
int addx[1010],addy[1010];
int main()
{
int T;
int i,j,a,b,t,n,m,q;
scanf("%d",&T);
while(T--)
{
memset(addx,0,sizeof(addx));
memset(addy,0,sizeof(addy));
scanf("%d%d%d",&n,&m,&q);
for(i=1;i<=n;i++)
{
x[i]=i;
for(j=1;j<=m;j++)
{
y[j]=j;
scanf("%d",&map[i][j]);
}
}
while(q--)
{
scanf("%d%d%d",&t,&a,&b);
if(t==1)
{
int tmp=x[a];
x[a]=x[b];
x[b]=tmp;
}
else if(t==2)
{
int tmp=y[a];
y[a]=y[b];
y[b]=tmp;
}
else if(t==3)
addx[x[a]]+=b;
else
addy[y[a]]+=b;
}
for(i=1;i<=n;i++)
{
printf("%d",map[x[i]][y[1]]+addx[x[i]]+addy[y[1]]);
for(j=2;j<=m;j++)
{
printf(" %d",map[x[i]][y[j]]+addx[x[i]]+addy[y[j]]);
}
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: