您的位置:首页 > 其它

poj 3069 (Saruman's Army)

2016-08-22 11:18 453 查看
  贪心

 Saruman's Army

  

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units,
and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units
of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s
army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n =
−1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input
0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output
2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed
to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

题意:直线上有n个点,点i的位置是xi,从这n个点中选择若干个标记,对每一个点,其距离为r以内的区域内必须有带标记的点,在满足这个条件的情况下,问至少需要标记多少点。
题解:理解了题意,就简单了,贪心,可以从最左边开始考虑,第一个标记的点应该是距离最左边以内为r的最远的点,采用同样的方法找到标记点右侧r距离以内最远的点标记,以此类推,直到所有点都被覆盖。
#include<cstdio>
#include<algorithm>
using namespace std;

int x[1010];
int main(){
int r, n, i;
while (scanf ("%d %d",&r,&n)!=EOF){
if (r==-1 &&n==-1) break;
for (i=1;i<= n; i++){
scanf ("%d",&x[i]);
}
sort (x+1,x+n+1);
i=1;
int ans=0;
while (i<=n){
int s=x[i++];//s是未覆盖的最左的点的位置
while (i<=n && x[i]<=s +r) i++;//直到距s的距离大于r
int p=x[i-1];//p是新加上标记的点的位置
while (i<=n && x[i]<=p+r) i++;//找到距p的距离大于r的点
ans++;
}
printf ("%d\n",ans);
}
return 0;

}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: