您的位置:首页 > 其它

Ekka Dokka

2016-08-21 21:31 155 查看
 

Description

Ekka and his friend Dokka decided to buy a cake. They both love cakes and that's why they want to share the cake after buying it. As the name suggested that Ekka is very fond of odd numbers and Dokka is very fond of even numbers, they want to divide the
cake such that Ekka gets a share of N square centimeters and Dokka gets a share of M square centimeters where N is odd and M is even. Both N and M are positive
integers.

They want to divide the cake such that N * M = W, where W is the dashing factor set by them. Now you know their dashing factor, you have to find whether they can buy the desired cake or not.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer W (2 ≤ W < 263). And W will not be a power of 2.

Output

For each case, print the case number first. After that print "Impossible" if they can't buy their desired cake. If they can buy such a cake, you have to print N and M. If there are multiple solutions, then
print the result where M is as small as possible.

Sample Input

3

10

5

12

Sample Output

Case 1: 5 2

Case 2: Impossible

Case 3: 3 4

很简单的一道题,给你一个数n,如果是奇数,直接输出“Impossible",否则,进行暴力解决,看这个数能否由一奇一偶构成,如果有多种,取偶数最小的那个

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
int t,h=1;
scanf("%d",&t);
while(t--)
{
long long l,i,k;
scanf("%lld",&l);
printf("Case %d: ",h++);
if(l&1)
{
printf("Impossible\n");
continue;
}
else
{
for(i=2;i<=l;i+=2)

if(l%i==0&&(l/i)&1)//注意判断(l%i==0)
{
printf("%lld %lld\n",l/i,i);
break;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: