您的位置:首页 > 其它

POJ1836——Alignment

2016-08-20 20:35 281 查看
Alignment

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 16038 Accepted: 5242
Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned
in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new
line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of
the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 

• 2 <= n <= 1000 

• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.
Sample Input
8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output
4

Source

Romania OI 2002
题意:

士兵拍成一行,让最少的士兵出列,使得每个士兵都能看到至少一个最边上的士兵(中间某个人能看到最边上的士兵的条件是该士兵的身高一定强大于他某一边所有人的身高),身高序列可以是这样:1  2  3   4   5   4   3   2   1  或者   1   2   3   4   5   5   4   3   2   1

思路:

记录每个人左边的最大升序列中的人数(注意:他自己也算一个并且身高严格递增),记录每个人右边的最大严格降序列的人数,也包括他自己。

然后代码中有第二种身高序列的处理。

#include <iostream>
#include <cstdio>
#include <cstdlib>

using namespace std;

int main()
{
int n;
cin>>n;
double *h = new double[n+1];
int *left = new int[n+1];
int *right = new int[n+1];

for( int i = 1;i <= n;i++ )
cin>>h[i];

for( int i = 1;i <= n;i++ )
{
left[i] = 1;
for( int j = i-1;j >= 1;j-- )
{
if( h[i]>h[j] && left[i]<=left[j] )
left[i] = left[j] + 1;
}
}

for( int i = n;i >= 1;i-- )
{
right[i] = 1;
for( int j = i+1;j <= n;j++ )
{
if( h[i]>h[j] && right[i] <=right[j] )
right[i] = right[j] + 1;
}
}

int cnt = 0;

for( int i = 1;i < n;i++ )
{
for( int j = i+1;j <= n;j++ )
{
if( cnt<left[i]+right[j] )
cnt = left[i]+right[j];
}
}
cout<<n-cnt<<endl;

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dp