您的位置:首页 > 其它

FZU 2214 Knapsack problem (0/1背包)

2016-08-20 19:06 357 查看
[align=center]Knapsack problem
[/align]

Time Limit: 3000 mSec    Memory Limit : 32768 KB



Problem Description

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible.
Find the maximum total value. (Note that each item can be only chosen once).



Input

The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v
<= 5000

All the inputs are integers.



Output

For each test case, output the maximum value.



Sample Input

1

5 15

12 4

2 2

1 1

4 10

1 2



Sample Output

15



Source

第六届福建省大学生程序设计竞赛-重现赛(感谢承办方华侨大学)

题目分析:http://acm.fzu.edu.cn/problem.php?pid=2214

题目大意:n个物品,背包限重B,每个物品价值vi,重量wi,求最大价值

题目分析:由于B很大而v的总和很小,定义dp[i]为价值为i时的最小重量做0/1背包
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const INF = 0x3fffffff;
int dp[5005], w[505], v[505];

int main() {
int T;
scanf("%d", &T);
while(T --) {
int n, B, sum = 0;
scanf("%d %d", &n, &B);
for(int i = 0; i < n; i++) {
scanf("%d %d", &w[i], &v[i]);
sum += v[i];
}
for(int i = 0; i < 5005; i++) {
dp[i] = INF;
}
dp[0] = 0;
for(int i = 0; i < n; i++) {
for(int j = sum; j >= v[i]; j--) {
dp[j] = min(dp[j], dp[j - v[i]] + w[i]);
}
}
int ans = 0;
for(int i = sum; i >= 0; i--) {
if(dp[i] <= B) {
ans = i;
break;
}
}
printf("%d\n", ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: