您的位置:首页 > 其它

poj1905 Expanding Rods(二分+几何)

2016-08-20 14:54 411 查看
Expanding Rods

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 15265 Accepted: 4059
Description


When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 

When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced. 

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod
expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.
Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 

Sample Input
1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output
61.329
225.020
0.000

题目大意:

一根某种材料做的直杆被夹在两面墙之间,当他受热时长度会变长,就会因两面墙的挤压而向上隆起。长度变化函数为 L'=(1+n*C)*L,给定L,C,n,求向上拱起的高度H。

解题思路:





这是两个最关键的计算式,可以手动计算出来。

然后对h进行二分查找。

注意:

1、误差分析,我的是到了10^-5才可以了。


2、注意输出。最好用cout。

s函数递增 适用二分求解

#include<stdio.h>
#include<math.h>
int main()
{
double s,l,c,n,r,h;
int i,j;

while(~scanf("%lf%lf%lf",&l,&n,&c))
{
if(l==-1&&n==-1&&c==-1)
{
break;
}

double low = 0;
double high = l;
double mid;

s=(1+n*c)*l;

while(high-low>0.000001)
{
mid = (high+low)/2;
r=(4*mid*mid+l*l)/(8*mid);
if(2*r*asin(l/(2*r))<s)
low=mid;
else high=mid;

}
printf("%.3lf\n",mid);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: