您的位置:首页 > 其它

POJ 2142 The Balance(扩展欧几里德)

2016-08-19 23:35 411 查看
The Balance

Description

Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights
on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights. 

You are asked to help her by calculating how many weights are required. 



Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using
a combination of a mg and b mg weights. In other words, you need not consider "no solution" cases. 

The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.
Output

The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions. 
You can measure dmg using x many amg weights and y many bmg weights. 

The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition. 

The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.

No extra characters (e.g. extra spaces) should appear in the output.
Sample Input
700 300 200
500 200 300
500 200 500
275 110 330
275 110 385
648 375 4002
3 1 10000
0 0 0

Sample Output
1 3
1 1
1 0
0 3
1 1
49 74
3333 1

原文链接:poj2142-The Balance(扩展欧几里德算法)
题目大意:有两个类型的砝码,质量分别为a,b;现在要求称出质量为d的物品,要用多少a砝码(x)和多少b砝码(y),使得(x+y)最小。(注意:砝码位置有左右之分)。 

解题思路:

        1,由题意得出两个方程

    i,ax1 - by1 = d ;

    ii,bx2 - ay2 = d 。 

  2,代入算法,解出两个方程的解(x1,y1)、(x2,y2),并求出最小x1和x2,以及相对应的y1,y2.

  3, 判断

    i,x1+y1最小时,输出x1,y1

    ii,x2+y2最小时,输出y2,x2。 *此处为y2在前面输出,因为x2+y2最小时,第一个输入的a对应的是y2。

代码如下:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
typedef long long ll;

int extended_euclid(int a,int b,int& x,int& y)
{
int d = a;
if(b){
d = extended_euclid(b,a % b,y,x);
y -= (a / b) * x;
}
else{
x = 1;
y = 0;
}
return d;
}

void solve(int a,int b,int d,int& x,int& y)
{
int g = extended_euclid(a,b,x,y);
x *= d / g;
int t = b / g;
x = (x % t + t) % t;
y = abs((a * x - d) / b);
}

int main()
{
int a,b,c,x1,x2,y1,y2;
while(scanf("%d %d %d",&a,&b,&c) != EOF && (a || b || c)){
solve(a,b,c,x1,y1);
solve(b,a,c,x2,y2);
if(x1 + y1 < x2 + y2)
printf("%d %d\n",x1,y1);
else
printf("%d %d\n",y2,x2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ