您的位置:首页 > 其它

【HDU】1069 - Monkey and Banana(dp)

2016-08-19 20:59 323 查看
点击打开题目


Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12862    Accepted Submission(s): 6755


Problem Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana
by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions
of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly
smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

 

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.

 

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

 

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

 

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

 

Source

University of Ulm Local Contest 1996

 

把1个长方体换成6种放的方式,然后sort后动态规划就行了。

代码如下:

#include <stdio.h>
#include <cstring>
#include <algorithm>
using namespace std;
#define CLR(a,b) memset(a,b,sizeof(a))
#define INF 0x3f3f3f3f
#define LL long long
struct node
{
int x,y,h; //让x >= y
}a[200];
int ant;
bool cmp(node a,node b)
{
if (a.x == b.x)
return a.y > b.y;
return a.x > b.x;
}
void PushUp(int t1,int t2,int t3)
{
a[ant].h = t3;
a[ant].x = t1;
a[ant].y = t2;
ant++;
a[ant].h = t3;
a[ant].x = t2;
a[ant].y = t1;
ant++;
a[ant].h = t2;
a[ant].x = t1;
a[ant].y = t3;
ant++;
a[ant].h = t2;
a[ant].x = t3;
a[ant].y = t1;
ant++;
a[ant].h = t1;
a[ant].x = t2;
a[ant].y = t3;
ant++;
a[ant].h = t1;
a[ant].x = t3;
a[ant].y = t2;
ant++;
}
int main()
{
int n;
int ans;
int dp[200];
int Case = 1;
while (~scanf ("%d",&n) && n)
{
ant = 1;
for (int i = 1 ; i <= n ; i++)
{
int t1,t2,t3;
scanf ("%d %d %d",&t1,&t2,&t3);
PushUp(t1,t2,t3);
}
ant--;
printf ("Case %d: maximum height = ",Case++);
sort (a+1 , a+1+ant , cmp);
ans = 0;
for (int i = 1 ; i <= ant ; i++)
{
dp[i] = a[i].h;
for (int j = i - 1 ; j >= 1 ; j--)
{
if (a[i].x < a[j].x && a[i].y < a[j].y)
dp[i] = max (dp[i] , dp[j] + a[i].h);
}
ans = max (ans , dp[i]);
}
printf ("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: