您的位置:首页 > 其它

HDU-1022/数组栈

2016-08-19 20:06 106 查看

Train Problem I

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 32049    Accepted Submission(s): 12094
[/b]

[align=left]Problem Description[/align]
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes
a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves,
train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your
task is to determine whether the trains can get out in an order O2.







 

[align=left]Input[/align]
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file.
More details in the Sample Input.

 

[align=left]Output[/align]
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out"
for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

 

[align=left]Sample Input[/align]

3 123 321
3 123 312

 

[align=left]Sample Output[/align]

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

HintHint
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".

 

[align=left]Author[/align]
Ignatius.L
 

#
4000
include"stdafx.h"

#include<stdio.h>

#include<string.h>

#include<iostream>

using namespace std;

#define M 100

char  a[M];

char  b[M];

char stack[M];//工作栈

int  result[M];//结果栈

int  tip[M];

int main()

{

 int i, j, k, p;

 bool flag = true;

 int n;

 while (scanf_s("%d",&n)!= EOF)

 {

  i = 0,j=0, k = 0, p = 0;

  flag = true;

  memset(tip, 0, sizeof(tip));

  memset(result, 0, sizeof(result));

  for (i = 1; i <= n; i++)

   tip[i] = -1;

  cin >> a;

  cin >> b;

  i = 0;

  //问题分为b[j]被标记的时候和没标记(相等)时候的出栈,反之既没有被标记和不相等的情况

  while (i!=strlen(a)||j!=strlen(b))

  {

   if (a[i] != b[j] && tip[b[j] - '0'] == -1)//进栈 (b[j]不在栈内)

   {

    stack[p++] =a[i];

    tip[a[i++] - '0'] = i;//表示在栈的位置

    result[k++] = 1;//结果栈,1表示input,0表示output  

   }

   else if (a[i] == b[j])

   {

    result[k++] = 1; result[k++] = 0;//入栈 出栈

    i++; j++;

    

   }

   else //b[j]在栈内if(tip[b[j]-'0'])

   {

    if (stack[p - 1] != b[j])

    {

     printf("No.\n");

     flag = false;

     break;

    }

    else

    {

     result[k++] = 0;//结果栈记录

     stack[--p] = 0;//出栈

     j++;

    }

   }

  }

  

  if (flag)

  {

   printf("Yes.\n");

   for (i = 0; i < k; i++)

    printf("%s\n",(result[i] == 1) ? "in" : "out");

  

  }

  printf("FINISH\n");

 }

  return 0;

 }
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: