您的位置:首页 > 其它

【HDU】2069 - Coin Change(暴力)

2016-08-19 19:33 260 查看
点击打开题目


Coin Change

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 17862    Accepted Submission(s): 6152


Problem Description

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents
with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.

 

Input

The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.

 

Output

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

 

Sample Input

11
26

 

Sample Output

4
13

 

Author

Lily

 

Source

浙江工业大学网络选拔赛

 

真·暴力解法。

代码如下:

#include <stdio.h>
#include <cstring>
#include <algorithm>
using namespace std;
#define CLR(a,b) memset(a,b,sizeof(a))
#define INF 0x3f3f3f3f
#define LL long long
int main()
{
int n;
int ans;
while (~scanf ("%d",&n))
{
ans = 0;
for (int i = 0 ; i <= n ; i++)
{
if (i > 100)
break;
for (int j = 0 ; j <= n/5 ; j++)
{
if (i+j > 100 || i+j*5 > n)
break;
for (int k = 0 ; k <= n/10 ; k++)
{
if (i+j+k > 100 || i+5*j+10*k > n)
break;
for (int p = 0 ; p <= n/25 ; p++)
{
if (i+j+k+p > 100 || i+5*j+10*k+25*p > n)
break;
for (int q = 0 ; q <= n/25 ; q++)
{
if (i+j+k+p+q > 100 || i+5*j+10*k+25*p+50*q > n)
break;
if (i+5*j+10*k+25*p+50*q == n)
ans++;
}
}
}
}
}
printf ("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: