您的位置:首页 > 其它

POJ 1017 Packets

2016-08-19 18:23 302 查看
Packets

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 51779 Accepted: 17578
Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because
of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels
necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.
Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest
size 6*6. The end of the input file is indicated by the line containing six zeros.
Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last
``null'' line of the input file.
Sample Input
0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output
2
1

题目大意:输入高相同,底面积分别为1*1 2*2 3*3 4*4 5*5 6*6的盒子个数 现在有底面积6*6的箱子 求把输入的所有盒子都装箱最少要用多少箱子

#include <iostream>
using namespace std;
int main()
{
std::cin.tie(false);
ios::sync_with_stdio(false);
int num[4] = { 0, 5, 3, 1 };
/*
如果箱子里没有放3*3的盒子则这个箱子暂时不放2*2的盒子
如果放了一个3*3的盒子 则还可以放五个2*2的盒子
如果放了两个3*3的盒子 则好可以放三个2*2的盒子
如果放了三个3*3的盒子 则还可以放一个2*2的盒子
*/
int a[10];
int ans;
while (1)
{
int sum=0;
ans = 0;
for (int i = 1; i <= 6; i++)
{
cin >> a[i];
sum+=a[i];
}
if(sum==0) break;
ans += a[4] + a[5] + a[6] + (a[3] + 3) / 4; //每一个4*4 5*5 6*6的盒子都要占用一个箱子
int box1, box2; //储存现在还能装入的1*1 2*2的盒子数
box2 = a[4] * 5 + num[a[3] % 4];
if (a[2] > box2)
{
ans += (a[2] - box2 + 8) / 9;
}
box1 = ans * 36 - a[6] * 36 - a[5] * 25 - a[4] * 16 - a[3] * 9 - a[2] * 4;
if (a[1] > box1)
{
ans += (a[1] - box1 + 35) / 36;
}
cout << ans << endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: