您的位置:首页 > 其它

HDU-2594 Simpsons’ Hidden Talents(KMP)

2016-08-19 17:45 381 查看
J - Simpsons’ Hidden Talents
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u
Submit Status Practice HDU
2594

Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had. 

Marge: Yeah, what is it? 

Homer: Take me for example. I want to find out if I have a talent in politics, OK? 

Marge: OK. 

Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix 

in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton 

Marge: Why on earth choose the longest prefix that is a suffix??? 

Homer: Well, our talents are deeply hidden within ourselves, Marge. 

Marge: So how close are you? 

Homer: 0! 

Marge: I’m not surprised. 

Homer: But you know, you must have some real math talent hidden deep in you. 

Marge: How come? 

Homer: Riemann and Marjorie gives 3!!! 

Marge: Who the heck is Riemann? 

Homer: Never mind. 

Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0. 

The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton
homer
riemann
marjorie


Sample Output

0
rie 3


题意:求字符串满足:是s1的前缀,且是s2的后缀。求符合条件的最长字符串。

思路:

1.连接两个字符串,就转化成了求一个字符串的最长前后缀。类似题目见Here

2.让s2为模式串去匹配s1.

1.

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N = 50005;
char s1[N*2],s2
;
int Next[N*2];
void Getfail(int m)
{
int i = 0, j = -1;
Next[0] = -1;
while(i < m)
{
if(j == -1 || s1[i] == s1[j])
Next[++i] = ++j;
else
j = Next[j];
}
}
int main()
{
while(~scanf("%s %s",s1,s2))
{
int m = strlen(s1),n = strlen(s2);
strcat(s1,s2);
int len = m + n;
Getfail(len);
int k = Next[len];
while(k > m || k > n)
k = Next[k];
if(k == 0)
printf("0\n");
else
{
for(int i = 0;i < k;i++)
printf("%c",s1[i]);
printf(" %d\n",k);
}
}
return 0;
}


2.

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N = 50005;
char s1
,s2
;
int Next
;
void Getfail(int m)
{
int i = 0, j = -1;
Next[0] = -1;
while(i < m)
{
if(j == -1 || s1[i] == s1[j])
Next[++i] = ++j;
else
j = Next[j];
}
}
int KMP(int n)
{
int i = 0,j = 0;
while(i < n)
{
if(j == -1 ||s2[i] == s1[j])
i++,j++;
else
j = Next[j];
}
return j;
}
int main()
{
while(~scanf("%s %s",s1,s2))
{
int m = strlen(s1),n = strlen(s2);
Getfail(m);
int ans = KMP(n);
if(ans == 0)
printf("0\n");
else
{
for(int i = 0;i < ans;i++)
printf("%c",s1[i]);
printf(" %d\n",ans);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: