您的位置:首页 > 其它

POJ Snowflake Snow Snowflakes 3349 (哈希)

2016-08-19 15:38 363 查看
Snowflake Snow Snowflakes

Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 38668 Accepted: 10138
Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake
has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake.
Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise),
but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.

If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input
2
1 2 3 4 5 6
4 3 2 1 6 5


Sample Output
Twin snowflakes found.


Source

CCC 2007
题意:给出雪花六个边的长度,不按顺序,判断是否有重复的雪花

分析:把每个雪花存入数组,再把每个雪花哈希,如果遇到哈希值相等的雪花,再一一比较,由于不按顺序,就是判断同构。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <vector>
using namespace std;
int k[110000][7];
#define Max 999983
vector<int >Ka[Max];
int bijiao(int x,int y)
{
int i,j,g;
for(i=0;i<6;i++)
{
if(k[x][0]==k[y][i])
{
g=1;
for(j=(i+1)%6;g<6;j=(++j)%6)//顺时针
{
if(k[x][g]==k[y][j])
{
g++;
}
else
{
break;
}
}
if(g==6)return 1;
g=1;
for(j=(i+6-1)%6;g<6;j=((--j)+6)%6)//逆时针
{
if(k[x][g]==k[y][j])
{
g++;
}
else
{
break;
}

}
if(g==6)return 1;
}
}
return 0;
}
int main()
{
int n,m,i,j,r;
int flag;
scanf("%d",&n);
int sum;
flag=0;
for(i=0;i<n;i++)
{
sum=0;
for(j=0;j<6;j++)
{
scanf("%d",&k[i][j]);
sum+=k[i][j];
}
r=sum%Max;
if(flag)
continue;
int l=Ka[r].size();
for(j=0;j<l;j++)
{
if(bijiao(i,Ka[r][j]))
{
flag=1;
break;
}
}
if(!flag)
{
Ka[r].push_back(i);
}
}
if(flag)
{
printf("Twin snowflakes found.\n");
}
else
{
printf("No two snowflakes are alike.\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: