您的位置:首页 > 其它

【poj1852】Ants

2016-08-18 21:23 381 查看
Ants

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 14948 Accepted: 6498
Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know
the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.
Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers
giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.
Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such
time. 

Sample Input
2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output
4 8
38 207
题意:有一群蚂蚁在一个木桩上走,方向不确定,两只蚂蚁相遇则回头走,走到端点处结束,输出所有蚂蚁走完所需的最长时间和 最短时间
题解:首先sort排序,最长时间好找,也就是最长距离,比较第一个点到终点的距离与最后一个点到起点的距离,大的即为最长时 间。最短时间就是所有点分别到起点和终点的较短时间中的最大值。
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[1000001];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int l,n;
scanf("%d%d",&l,&n);
int minm=0;
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
int s=a[i]>l-a[i]?l-a[i]:a[i];
minm=max(minm,s);

}
sort(a+1,a+n+1);
int maxm=max(l-a[1],a[n]);
printf("%d %d\n",minm,maxm);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: