您的位置:首页 > 其它

poj2406(KMP 求循环节的个数)Power Strings --

2016-08-18 19:30 134 查看
                                              Power Strings
Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined
in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.


Sample Output

1
4
3


Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.
#include<stdio.h>
#include<string.h>
char a[1000000];
int p[1000000],n,m,ans;
void fail() //p数组构造
{
int i=0,j=-1;
p[0]=-1;
while(i<m)
{if(a[i]==a[j]||j==-1)
{j++;
i++;
p[i]=j;}
else
j=p[j];
}
}
int main()
{
while(scanf("%s", a), strcmp(a, "."))
{
m=strlen(a);
fail();
if(m%(m-p[m]))
printf("1\n");
else
printf("%d\n",m/(m-p[m]));

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: