您的位置:首页 > 其它

POJ 2187 Beauty Contest(凸包)

2016-08-18 10:16 495 查看
Beauty Contest

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 34900 Accepted: 10800
Description

Bessie, Farmer John's prize cow, has just won first place in a bovine beauty contest, earning the title 'Miss Cow World'. As a result, Bessie will make a tour of N (2 <= N <= 50,000) farms around the world in order to spread goodwill between farmers and their
cows. For simplicity, the world will be represented as a two-dimensional plane, where each farm is located at a pair of integer coordinates (x,y), each having a value in the range -10,000 ... 10,000. No two farms share the same pair of coordinates. 

Even though Bessie travels directly in a straight line between pairs of farms, the distance between some farms can be quite large, so she wants to bring a suitcase full of hay with her so she has enough food to eat on each leg of her journey. Since Bessie refills
her suitcase at every farm she visits, she wants to determine the maximum possible distance she might need to travel so she knows the size of suitcase she must bring.Help Bessie by computing the maximum distance among all pairs of farms. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two space-separated integers x and y specifying coordinate of each farm 

Output

* Line 1: A single integer that is the squared distance between the pair of farms that are farthest apart from each other. 

Sample Input
4
0 0
0 1
1 1
1 0

Sample Output
2

Hint

Farm 1 (0, 0) and farm 3 (1, 1) have the longest distance (square root of 2) 

Source
USACO 2003 Fall

大体题意:给出n个点,求相距最远的两个点之间距离的平方。
思路:凸包的模板题,相距最远的点肯定在所求凸包的边界上,所以求出凸包后枚举即可。

#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
#include<iostream>
#include<cmath>
using namespace std;
typedef long long ll;

struct Point
{
int x,y;
Point(int x = 0, int y = 0) : x(x), y(y) {}
friend Point operator - (const Point& A, const Point& B)
{
return Point(A.x-B.x, A.y-B.y);
}
bool operator < (const Point& B) const
{
return x < B.x || x == B.x && y < B.y;
}

};

int Cross(const Point& A, const Point& B)
{
return A.x*B.y - A.y*B.x;
}

ll dist(const Point& A, const Point& B)
{
return (ll)(A.x-B.x)*(A.x-B.x) + (ll)(A.y-B.y)*(A.y-B.y);
}

const int maxn = 50000 + 5;
Point p[maxn];

int n;

void solve()
{
sort(p,p+n);
vector<Point> ch(n*2);
int m = 0;
for (int i = 0; i < n; i++) {
while (m > 1 && Cross(ch[m-1]-ch[m-2], p[i]-ch[m-1]) <= 0) m--;
ch[m++] = p[i];
}
int k = m;
for (int i = n-2; i >= 0; i--) {
while (m > k && Cross(ch[m-1]-ch[m-2], p[i]-ch[m-1]) <= 0) m--;
ch[m++] = p[i];
}
ch.resize(m);
ll mx = -1;
for (int i = 0; i < ch.size(); i++)
for (int j = i+1; j < ch.size(); j++)
mx = max(mx, dist(ch[i],ch[j]));
cout << mx << endl;
}

int main()
{
scanf("%d",&n);
for (int i = 0; i < n; i++) {
scanf("%d%d",&p[i].x,&p[i].y);
}
solve();
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: