您的位置:首页 > 其它

UVA10054 The Necklace (输出欧拉回路)

2016-08-18 00:34 471 查看
My little sister had a beautiful necklace made of colorful beads. Two successive beads in the necklace

shared a common color at their meeting point. The gure below shows a segment of the necklace:

But, alas! One day, the necklace was torn and the beads were all scattered over the oor. My sister

did her best to recollect all the beads from the oor, but she is not sure whether she was able to collect

all of them. Now, she has come to me for help. She wants to know whether it is possible to make a

necklace using all the beads she has in the same way her original necklace was made and if so in which

order the bids must be put.

Please help me write a program to solve the problem.

Input

The input contains

T

test cases. The rst line of the input contains the integer

T

.

The rst line of each test case contains an integer

N

(5



N



1000) giving the number of beads

my sister was able to collect. Each of the next

N

lines contains two integers describing the colors of a

bead. Colors are represented by integers ranging from 1 to 50.

Output

For each test case in the input rst output the test case number as shown in the sample output. Then

if you apprehend that some beads may be lost just print the sentence \

some beads may be lost



on a line by itself. Otherwise, print

N

lines with a single bead description on each line. Each bead

description consists of two integers giving the colors of its two ends. For 1



i



N

1, the second integer

on line

i

must be the same as the rst integer on line

i

+ 1. Additionally, the second integer on line

N

must be equal to the rst integer on line 1. Since there are many solutions, any one of them is

acceptable.

Print a blank line between two successive test cases.

SampleInput

2

5

1 2

2 3

3 4

4 5

5 6

5

2 1

2 2

3 4

3 1

2 4

SampleOutput

Case #1

some beads may be lost

Case #2

2 1

1 3

3 4

4 2

2 2

题解:

一开始就是以为输出一个环,结果发现怎么搞都搞不过。。

后来才知道这是个欧拉回路,我真的智商。。够了。。。

好吧。。

判断一下欧拉回路是否存在,其实需要判断一下图是否联通的,但是这道题数据貌似都是联通的。需要倒着输出的原因是递归,不然你用vector存下来反着输出也行,不过还是没必要。

#include<iostream>
using namespace std;
#include<cstdio>
#include<cstring>
#include<vector>

const int maxn=2005;

int a[maxn][maxn],in[55];

void dfs(int now){
for(int i=1;i<=50;++i){
if(a[now][i]>0){
--a[now][i],--a[i][now];
dfs(i);
printf("%d %d\n",i,now);
}
}
}
int main() {
#ifdef tangge
freopen("UVA10054.in","r",stdin);
#endif // tangge
int n,u,v,Tcase=1,T;
scanf("%d",&T);
while(T--) {
scanf("%d",&n);

memset(a,0,sizeof(a)),memset(in,0,sizeof(in));
for(int i=0;i<n;++i){
scanf("%d%d",&u,&v);
++in[u],++in[v];
++a[u][v],++a[v][u];
}
bool J=true;
for(int i=1;i<=50;++i){
if(in[i]&1){
J=false;break;
}
}
if(Tcase>=2)putchar(10);
printf("Case #%d\n",Tcase++);
if(!J)
printf("some beads may be lost\n");
else {
for(int i=1;i<=50;++i){
if(in[i]>0){
dfs(i);break;
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: