您的位置:首页 > 编程语言 > C语言/C++

POJ 3159 Candies

2016-08-17 21:58 316 查看
Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers
of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies
fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another
bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 throughN.
snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies
more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input
2 2
1 2 5
2 1 4

Sample Output
5

Hint

32-bit signed integer type is capable of doing all arithmetic.
Source
POJ Monthly--2006.12.31, Sempr
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

差分约束系统裸题~条件都不用变化的~

stack居然没有清空函数,惊呆了~好久没用都忘掉了……然后,想要清空就得用while(!sta.empty()) sta.pop(); ~

这道题用queue会超时,第一次用stack写的SPFA呢~

(G++编译过不了……至今不明白为什么……)(用C++提交的~)

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int n,head[30005],t,a,b,c,vis[30005],tol,Q[30005],dist[30005];

struct node
{
int to;
int v;
int next;
}edge[150005];

void add(int a,int b,int v)
{
edge[tol].to=b;
edge[tol].v=v;
edge[tol].next=head[a];
head[a]=tol++;
}

void spfa(int start,int n)
{
int top=0;
for(int v=1;v<=n;v++)
{
if(v==start)
{
Q[top++]=v;vis[v]=1;dist[v]=0;
}
else
{
vis[v]=0;dist[v]=INT_MAX;
}
}
while(top)
{
top--;
int u=Q[top];
vis[u]=0;
for(int i=head[u];i!=-1;i=edge[i].next)
{
int v=edge[i].to;
if(dist[v]>dist[u]+edge[i].v)
{
dist[v]=dist[u]+edge[i].v;
if(!vis[v])
{
vis[v]=1;
Q[top++]=v;
}
}
}
}
}
int main()
{
while(scanf("%d%d",&n,&t)!=EOF)
{
tol=0;
memset(head,-1,sizeof(head));
while(t--)
{
scanf("%d%d%d",&a,&b,&c);
add(a,b,c);
}
spfa(1,n);
printf("%d\n",dist
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ 差分约束系统